Back to overview
Degraded

Network Issues Reported by our Cloud Provider

Jul 30 at 02:56pm CEST
Affected services
app.kiflo.com
api.kiflo.com

Resolved
Jul 30 at 10:08pm CEST

The services affected by the current incident have been resolved.

**What do we know so far?

According to our cloud provider, an unexpected usage spike caused network components to perform below acceptable thresholds, resulting in intermittent errors, timeouts, and latency spikes.

The initial trigger event was a Distributed Denial-of-Service (DDoS) attack, which activated their DDoS protection mechanisms. However, initial investigations suggest that an error in implementing their defenses amplified the impact of the attack rather than mitigating it.

**What happens next?

Our team will conduct an internal retrospective to thoroughly understand the incident and gather insights for future improvements.

Updated
Jul 30 at 09:50pm CEST

The mitigation approach taken by our cloud provider has successfully reduced the impacts on Kiflo.

We will continue to monitor this closely.

Updated
Jul 30 at 06:14pm CEST

Our cloud provider has implemented networking configuration changes and has performed failovers to alternate networking paths to provide relief.

Their monitoring telemetry shows improvement in service availability from approximately 14:10 UTC onwards, and they continue to monitor to ensure full recovery.

Updated
Jul 30 at 04:32pm CEST

Multiple engineering teams from our cloud provider are engaged to diagnose and resolve the issue as soon as possible. They've identified multiple workstreams and are working to mitigate impacted workstreams by performing failover operations.

More details will be provided as they become available.

Created
Jul 30 at 02:56pm CEST

Our cloud provider is experiencing issues with its network infrastructure. Kiflo services might be degraded.

More details will be provided as they become available.